Enable egress-gateway on Istio 1.4.1

Hi,
Using below command I deployed istio and the egress gateway is not getting created
./bin/istioctl manifest apply
–set values.global.proxy.accessLogFile=/dev/stdout
–set values.global.disablePolicyChecks=false
–set values.grafana.enabled=true
–set values.grafana.security.enabled=true
–set values.grafana.persist=true
–set values.grafana.storageClassName=managed-premium
–set values.grafana.accessMode=ReadWriteOnce
–set values.tracing.enabled=true
–set values.kiali.enabled=true
–set values.global.controlPlaneSecurityEnabled=false
–set values.gateways.istio-egressgateway.enabled=true
I also tried the following command after executing above command but still the egress isn’t getting enabled
istioctl manifest apply --set values.global.istioNamespace=istio-system
–set values.gateways.istio-ingressgateway.enabled=false
–set values.gateways.istio-egressgateway.enabled=true

Thanks,
Saifullas.

Using IstioControlPlane the issue was resolved.

1 Like

This is a bug, see https://github.com/istio/istio/issues/19799. A fix should be out soon hopefully. Thanks!

1 Like