ISTO only working on port 80

I have installed ISTIO as a rancher App using the Rancher App market place. I then installed kubeflow.

By default Kubeflow creates an ISTIO gateway that listens on port 80. This works fine and I can access the ISTIO dashboard.

If I try to change the port on the gateway to anything other than port 80 I am unable to connect to the dashboard. Also setting up the connection as HTTPS does not work.

I get the error message in the browser, “The site can’t be reached”

Does anyone have any ideas how I can debug this issue.