Ldap won't run after integration with istio

Before integrating LDAP with istio in k8s, it starts okay and other services can connect to it. After I integrate istio with a service defination showed below ldap won’t even start.

apiVersion: v1
kind: Service
metadata:
  name: opendj
  namespace: default
  labels:
    app: opendj
    helm.sh/chart: opendj-1.0.1
    app.kubernetes.io/instance: RELEASE-NAME
    app.kubernetes.io/version: "4.0.0"
    app.kubernetes.io/managed-by: Helm
spec:
  ports:
    - port: 4444
      targetPort: 4444
      name: tcp-admin
    - port: 1389
      targetPort: 1389
      name: tcp-ldap
    - port: 1636
      targetPort: 1636
      name: tcp-ldaps
    - port: 8989
      targetPort: 8989
      name: tcp-repl
  type: ClusterIP
  selector:
    app: opendj

Below is a snippet of the logs I am getting in ldap container.

WARNING - entrypoint - 2020-02-24 18:40:39,002 - Exception in thread "main" java.lang.IllegalArgumentException: Invalid network port provided: 0 is not included in the [1, 65535] range.
	at org.opends.server.types.HostPort.normalizePort(HostPort.java:362)
	at org.opends.server.types.HostPort.<init>(HostPort.java:218)
	at org.opends.quicksetup.UserData.setHostName(UserData.java:167)
	at org.opends.quicksetup.UserData.<init>(UserData.java:119)
	at org.opends.server.tools.InstallDS.execute(InstallDS.java:329)
	at org.opends.server.tools.InstallDS.mainCLI(InstallDS.java:268)
	at org.opends.server.tools.InstallDS.mainCLI(InstallDS.java:235)
	at org.opends.quicksetup.installer.SetupLauncher.launch(SetupLauncher.java:108)
	at org.opends.quicksetup.installer.SetupLauncher.main(SetupLauncher.java:55)

INFO - entrypoint - 2020-02-24 18:40:45,471 - Configuring OpenDJ.
WARNING - entrypoint - 2020-02-24 18:40:48,702 - 
Unable to connect to the server at
"istio22-opendj-0.opendj.default.svc.cluster.local" on port 4444

I have tried setting LDAP connection handler to true but to no avail.
I have enabled auto-injection in my cluster and all these I have tried in both minikube and GKE.

I would appreciate a lot any help that comes this way. Thanks

Someone help out please. Any leads pleads