Traffic Shifting not showing Up in Kiali

Hi, Could someone give us some help. Trying to get the ‘traffic shifting’ to work in my Kiali. I am using versioning with all my services (3 of them). Just trying to turn off traffic in one of the version (v1) and shoot over to version 3. When I go into ‘service’ in Kiali to change the traffic, all the options are greyed out. I have tried upgrading from Istio 1.7.4 to 1.8.1 and also Kiali from version 1.22 to 1.28. This does not help. Please help.

When you say “traffic shifting” - do you mean traffic mirroring? If so, see these two:

What I mean is traffic shifting also called ‘updated weights’. Shifting traffic from one service to another service. So if one is 70% I change that to 0% and then the other version then get’s live traffic of 70%. For canary deployments. Thanks.

Feel free to open a discussion topic directly in Kiali Github Discussions for something like this: Discussions · kiali/kiali · GitHub

This sounds like something @lucas.ponce would know about.

Maybe a permissions issue? Maybe you have only view permissions?

@mars9876 some checks:

  • all workloads have the app and version labels ?
  • do you have a previous DR/VS created ? Kiali Wizards expect to generate all config from scratch ?
  • also, a permission issue, in case that Kiali is in readonly mode.

Let me know more details, I’d like to know if there is a bug or a missing edge in the logic.

Thanks

Hi Lucas, Thank You much for your response. I do have the app and version labels and the DR/VS are created. Did you want to see the files? As far as Kiali, we have update access and not just Read Only. Thank You.

Hi jshaughn, Can you tell me how to verify in Kiali what permission I have? Thanks!

Perhaps that’s the issue, if you created the DR/VS outside Kiali you can see them from the “Istio Config” section, but Wizards manage scenarios created by the scratch from Kiali.
(They don’t support yet all combinations of DR/VS).

Trick:
VS/DR generated by Kiali have a special label called "kiali_wizard: " to be opened by the Wizard.

The reason about this is that a Wizard manages a set of Istio Config: VirtualServices, DestinationRules, Gateways, and PeerRequests, but from user perspective the goal is to simplify that to the user.

Let me know if that helps.

To support any existing VS/DR combination with the Wizards is something we are working on, but the number of edges are high and we are focused on well known scenarios first.

I actually have the label in my VS. The DR/VS are created outside of Kiali and deployed using ISTIO. Here’s the piece that shows the label: apiVersion: networking.istio.io/v1alpha3
kind: VirtualService
metadata:
name: xxxxxxxxxxxxx
labels:
kiali_wizard: traffic_shifting

The ‘xxxxxxxxxxx’ is our service name. Thanks!

Hi Lucas, Is there something buggy with Istio 1.8.1 and Kiali 1.28? I found out that the only way to get the ‘traffic shifting’ to show up is to ‘delete the current traffic routing’. When it does the problem is that it changes the destination rules with the basic. It removed the match filtering set for headers and prefix that was there before. Could not restore it back. If I changed the ‘traffic shifting’ the whole traffic just stops. And if I go to Istio-config and change the YAML file directly, nothing happens. I exhausted all options and will be downgrading back to Istio 1.5.4 or 1.6. At least the ‘updated weights’ were working there. Thanks.

Also to add, when I do a ‘kubectl replace -f…’ with a YAML file that swaps the traffic shift, then I get this error in kiali’ user ‘traffic shifting’ > ’ Sorry, there was a problem. Try a refresh or navigate to a different page.’. It won’t let me change the traffic. :unamused:

Hey mars9878, sorry, I missed the notifications, my bad.

Kiali Wizards define scenarios, once you have defined one (involving VS/DR/GW/Security) it allows to update / delete that scenario and create a new one.

The more flexible one is the Request Routing one.

Would you like to move the discussion to Istio’s Slack or Freenode on [1] perhaps we can share some screenshots and I could see if there is anything else in your enviornment !

Thanks, and sorry again for my delay, I didn’t see it on my inbox.

[1] Kiali: Service mesh observability and configuration

Hi Lucas, I am definitely interested in what you are speaking of. But I don’t have access to the Freenode or Slack through my company web. Is there any other way we can talk about this? We are really needing this to get resolved ASAP as it is impacting the deployment of ISTIO across our environments today. Thank You again for your help.

Hi mars9876, we are usually on the freenode #kiali room that you can access via a simple web client like this:

https://webchat.freenode.net/#kiali

I’m on UTC+1 Timezone

Also, accessing to Istio slack just require a web client, in the kiali room there are more folks there to share any potential experience you have.

All methods to IM are described in:
https://kiali.io/contribute/#_talk_with_us

Hi Lucas, Can we go ahead and meet thru Slack? Thanks.

Sure.
Join anytime (I’m usually online on Europe timezone UTC+1) in Istio slack, kiali room.
Or alternative, feel free to use the kiali room on Freenode IRC (in one of the posted links you have webclient for direct access).

Some folks of Kiali team are always there.

Thanks

Hi Lucas, I have been online in the kiali web chat (free node). How do I find you? Thanks. Mary

You are European time. We are Central US time. Guess best time to reach you is early in the morning?

Lucas, please don’t make me go to that free node kiali web chat again. Whatever that was. I posed my questions and nobody was answering me. If anything they asked me to move to the ‘kiali discussion’ in GitHub. And it just sat there. Please let me know when you are available and we can get together. Thank You.