Data Plane and Pilot in diferent versions

I have the following problem.
I’m using eks going up with terraform and when going up the istio in version 1.7.3, everything was perfect.
A developer on my team had the idea of ​​using istioctl, but it was in version 1.6.5. After trying to update the istioctl client binaries, he ended up donating the data plane and pilot that were in version 1.7.3 to 1.6.5. How can I reverse this? When I run the pipeline it does not overwrite the data plane or the pilot.

For the most part you should be able to deploy them on top of each other without issues (unless you are using 1.7 new features). How are you deploying Istio? via istioctl install? You can use istioctl manifest generate to view the kubernetes yaml that gets deployed and debug why its not getting overlaid.

Thanks for supporting Nick.
So at first we went up by terraform using Helm with istio-charts in version 1.7.3.
And after Dev tried to use an istioctl bin export, he ended up making this error.
When running the pipeline again it does not adjust the data plane or the pilot.

Im guessing that your helm chart is still assuming 1.7.3 is deployed therefore does not need to deploy. You might be able to invalidate the terraform state for the helm chart and force a redeploy?

1 Like

Nick, it worked.
Thank you very much for your support.

1 Like