Enable STRICT MTLS for external clients

#1

I have a flat network and each pod has a routable IP.

Setup

I have enabled MTLS -

  1. DestinationRule has tls MUTUAL (should not matter in this case)
  2. Policy - is said to STRICT TLS.

I am using my own CA and want a client outside the mesh to access an MTLS enabled service inside the mesh.

My findinds

Istio-proxy logs on the service pod show has_user: false when client is external.
Shows has_user: true when client is internal.

Question

Is it even possible to do what I am trying to do? In the migration document its mentioned existing clients using plain text.

0 Likes

#2

I don’t think there will be a problem if you configure everything correctly.

Could you be more explicit what’s the error you see? Are you using the same CA for issuing certs inside and outside the cluster? The external client connects to the Pilot to get the secure naming info?

0 Likes

#3

Thanks for checking back Oliver.

The issue got resolved, the client cert I used did not have URI: entry in its SAN, hence it was getting rejected.

0 Likes

#4

@Oliver - I got it working for an external client.

But I have two clients, internal (in mesh) and external.

To enforce in mesh client MTLS, I need DestinationRule.

When I have DestinationRule with MUTUAL policy, then it blocks external client (which passes client certs)

If I remove DestinationRule or use mode: DISABLE then it works.

Have you tested this scenario?

0 Likes