Expose virtual service with global mTLS enabled

Hi all,
I’ve got some problem in exposing virtual service with mTLS enabled.
I’ve tried to expose Grafana but I got HTTP ERROR 503

I’ve tried this on GKE with strict istio enabled.
Someone can help?

did you try these?

yep but it is not working, i think the issue is related to istio version (in my case 1.2.5).
I tested on gke with 1.3.2 and it woks. @mudit_singh have you noticed any similar issue?

I have tried on 1.2.7 and 1.3.1 it works fine in them.