How to force Istio to use http/1.1?


On our Kubernetes Cluster, we use microservices and tomcat services set to work with http/1.1.

I’ve discovered that using Istio Ingress provides requests to my apps with http/2. I have set up the h2UpgradePolicy to DO_NOT_UPGRADE, but the connection still keeps being negociated with http/2.

I need Istio Ingress to force http/1.1 to be used, or something equivalent to the use-http2: “false” parameter with nginx-ingress.

Is there any way to achieve this?

P.S. : I have informed our dev teams that using http/2 should be something to begin to work on, and they agree, but they also said it would take extensive time for them to test everything, so I am looking for a workaround with Istio-Ingress until they are ready.

P.S.2: we are using istio 1.11.1

Best Regards,