How to set password to a redis ServiceEntry

hi all

I register my redis-server as a ServiceEntry

kind: ServiceEntry
  name: istio-demo-redis
  namespace: default
    - istio.redis.db
    - name: redis
      number: 6379
      protocol: REDIS
  location: MESH_EXTERNAL
  resolution: STATIC
    - address:
  exportTo: ~
  subjectAltNames: ~

I am enable the redis protocol support on pliot
when i use client to connect the server

	client := redis.NewClient(&redis.Options{
		Addr:     "",
		Password: "istioRedisTest123", // no password set
		DB:       0,                   // use default DB
	pong, err := client.Ping().Result() //

return error ERR Client sent AUTH, but no password is set

I am really set the password in redis.Options and the code works well when I use tcp proxy.
I checked the envoyproxy docs,it set the password in envoy config,how to set it in istio? or why cant auth with redis options

Try to change spec.ports.protocol from REDIS to TCP

I know tcp proxy can fix it,but it not a good solution to the problem。

+Zhonghu Xu
I think Redis Filter pilot builds, doesn’t add an option to add password(
Probably need a config to do the same…
Can you please open a bug for the same?

I open a issue for the case