Ingress Gateway istio-config when installed in a custom namespace

Hello, dear folks. How are you? Can someone help me with a doubt?

I’m using helm templates as the default installation method for Istio (without IstioOperator), according to the is expected that now (v1.5+) as a good practice I create my Istio Ingress-Gateways in a namespace other than istio-system due to security and maintainability matters.

When I checked the installation I saw that the new Istio Ingress was not sending spans to my custom Zipkin domain but instead was using the default one: zipkin:9411. Digging further I checked that the proxy’s configuration was not inheriting my tracing configuration based on the istio configmap. Any other namespaces inside the ServiceMesh (istio-injection: enabled) inherit the configuration correctly at the istio-system namespace.

What I would like to know is either how to configure tracing for an istio ingress configured in a namespace different than istio-system based on its values.yaml or inherit from the pilot’s one without having to manually clone the configmap to the istio ingress’ namespace, which works due to an optional mountVolume:

kubectl get deployment istio-ingressgateway -o yaml -n istio-gateways

      - name: config-volume
          name: istio
          optional: true

According to the chart, this configmap is only created by istio-pilot and it’s located at the rootNamespace istio-system only.