Istio 1.4.10: Do not request client certificate on ingress


Running Istio 1.4.10-gke.4 in GKE.

I am serving HTTPS through an ingress gateway. Only a server certificate is configured. No authentication.

Problem: a small subset of users, running (older) Android and (latest) Chrome, receive a “No certificates found” popup when visiting the site hosted through the ingress. I assume this is because a client certificate is being requested in the SSL handshake.

Is there a way to disable the ingress requesting a client certificate in the SSL handshake?

Thank you :slight_smile: