Istio tutorial doesn't work on Minikube

#1

I’m trying to get this tutorial to work on my local minikube on osx with hyperkit. I’m following this tutorial:

It fails after applying the DestinationRule. The pods should be getting 200s when pinging each other but instead still get 503s. I’ve tried installing istio with kubectl and with helm per instructions. Same result. The pods are running with the istio sidecar. I’ve also tried deleting and redeploying the pods after applying the DestinationRule to try to get the new pod to pick up the rule. But no success.

Any ideas? Am I doing something wrong? Is there something unintuitive about Minikube that might be affecting me?

Thanks!

1 Like

#2

The solution for me was to apply the DestinationRules to the “foo” and “bar” namespaces specifically. Then the pods could ping each other. The tutorial has us applying the rules to the default namespace.

Also, note that installing istio from Helm with mtls enabled = true doesn’t have this issue. The chart applies a destination rule to the istio-system namespace which seems to work.

0 Likes

#3

msoule,

I’ve filed a bug here for your issue:

I’d encourage you to file further bugs you run into here as well: https://github.com/istio/istio/issues/new/choose

Cheers
-steve

0 Likes