Kiali complains about incorrect configuration (KIA1101), but hosts exist

Hey all,

Got around to installing Kiali to get some insight into how my mesh is working, and it’s complaining about errors in Istio config. More precisely, it states all my VS have errors (KIA1101: DestinationWeight on route doesn’t have a valid service (host not found)). Thing is, that the services exist and Istio is routing traffic just fine. It even complains about ingress-gateway. Example:

    - '*'
    - istio-ingressgateway
    - match:
        - headers:
              prefix: GoogleHC
            exact: GET
            exact: /
        authority: 'istio-ingressgateway.istio-system.svc.cluster.local:15021'
        uri: /healthz/ready
        - destination:
            host: istio-ingressgateway.istio-system.svc.cluster.local
              number: 15021

It complains that host: istio-ingressgateway.istio-system.svc.cluster.local doesn’t exist.

Any idea what I could be missing here, or is this a case of ignoring what Kiali is telling me?


Hi @pslobo, I’ll take a look to your config, are you using Istio 1.10 ?

Hi @lucas.ponce, yeah just upgraded to 1.10. Which configs do you need from me? I’ve kept things relatively simple for now so finding it odd Kiali is throwing this error.

Thanks for confirming, let me test on a local env and back to you to confirm the issue.

I may need additional info, I’m also setting a similar VS as you have:

And I can’t get that error ?

Would you mind to open an issue Issues · kiali/kiali · GitHub and attach your config ?
Perhaps I’m missing something.

There is a patch for corner cases when hosts are present in the IstioD registry that it will be released in Kiali 1.35 (28th May); probably it will solve your problem, but with more info I will be able to confirm.

Thanks !

Thanks for looking into this @lucas.ponce I’ll share info on the ticket. Only thing I can think of that is different is that I’ve got the VS deployed to default NS. But I’ll try with 1.35 and if the issue persists, I’ll open a ticket for sure.