Primary-primary Multicluster setup not working in EKS

Hi Istio Community,

I have been trying to install istio for multicluster (primary-primary) setup.

While doing so, everything happens except Verifying Cross-Cluster Traffic step.

The command at the last returns the same cluster output and toggle between v1 and v2 not happening.

Could anyone help on this?


Same here I’m getting "upstream connect error or disconnect/reset before headers. reset reason: local reset " Only the version worked in the same cluster. How to debug?

All pod gateway everything looks normal, here is my “istioctl proxy-status” Any clue help is appreciated.

@Nahidul_Kibria, I’m also getting the same error

I’m not sure what we are missing, I will try one more time and let you know @ramanarayanan-ravi also can work together in a zoom call if you want, I’m in GMT+7 timezone. This is a cool feature to have and explore.

Hi @Nahidul_Kibria ,
Have you tried one more time?
I’m in GMT +5.30 timezone

I have similar problems with multucluster setup on AWS EKS

1 Like

Have you generated common root CA certs? In my experience, this was one of the things that tripped me.

FWIW, I was able to make the verification work in 1.8 on EKS.

1 Like

This is a good clue, I do following the root CA certs installation, I tried “Install Multi Primary on different networks” However I always get a response from the service installed in the same cluster.

Any clue how to debug? I do not find anything in gateway logs.

Did you solve this? I’m facing the same issue

Hi @mikala,
Sorry that I did not notice your message, I spent a huge time on this but found other few open issues like, Today google to see anything new someone post, I found this issue MultiCluster communications fail randomly after 30 minutes · Issue #31464 · istio/istio · GitHub

I decided to wait for more to see these features become stable, kind of also disappointed. Please reply back here if you can make some progress.