Rate limited grpc status code

I have used redisquota to successfully rate limit a grpc service. But when the grpc service is rate limited, the response that I get back has the grpc status code set to “UNAVAILABLE.”

I would prefer to have the grpc status be set to RESOURCE_EXHAUSTED. Is this possible to do? I saw this change to envoy that allows for:

// Specifies whether a RESOURCE_EXHAUSTED gRPC code must be returned instead
// of the default UNAVAILABLE gRPC code for a rate limited gRPC call. The
// HTTP code will be 200 for a gRPC response.

Can I enable this feature with an envoy filter and have it work for redisquota?