Unable to hit the Istio in Hyper V Ubuntu VM

I followed the getting started instructions from website (Istio / Getting Started) in the hyper v and the VM OS is Ubuntu.

I was able to install the Istio. The deployment of the saple application book info was done. I am using minikubu. When I run the command kubectl get services or pods, I do see the list matching what’s on the website. The status does show running.

I ran this command ( kubectl exec "(kubectl get pod -l app=ratings -o jsonpath=’{.items[0].metadata.name}’)" -c ratings – curl -s productpage:9080/productpage | grep -o “.*”
) and I got the successful response of getting the title of the page. The minikube tunnel console also show it is running and no errors for minikube, router, and loadbalancer emulator.

I got stuck on the verify external access. I ran this command (echo “http://$GATEWAY_URL/productpage”) to get the url to hit. I was not able to hit it when I run it outside of the VM (in my host computer) or when I hit it locally on the Ubuntu VM. On Ubuntu, I even tried to hit using and I still was not able to hit it.

Please help me with understanding which part of the setup I got it wrong.