Automatic Sidecar injection fails because of missing sidecar template

I freshly deployed K8S 1.21.1, with Istio 1.10.0 and Calico 1.19.1. Everything works fine so far, however the automatic sidecar injection fails with following error:

create Pod prometheus-0 in StatefulSet prometheus failed error: admission webhook "" denied the request: failed to run injection template: requested template "sidecar" not found;

I already restarted Istiod and it sends me this warning:

2021-06-17T12:45:41.022191Z     warn    injection templates are empty. This may be caused by using an injection template from an older version of Istio. Please ensure the template is correct; mismatch template versions can lead to unexpected results, including pods not being injected.

Since around 4 hours I try to find out by googling and searching this forum how to create such a template and so on, however I cannot find anything. Additionally the template should be available, since the CM “istio-sidecar-injector” exists in istio-system namespace.

I already doublechecked if the Admission- and Validation Webhook plugins are enabled in K8S (they are), so I think the problem is related to this template stuff. And in the namespace the Label “istio-injection=enabled” is also set.

K8S was installed via Kubeadm (quite basically) and Istio was installed via istioctl using the “default” profile, which is suggested for production.

May someone else does have any Idea what todo.

Problem solved, injection failed because I added some suggested Manifest form calico for conjunction use with istio.

After that I had a problem with the istio-init container because of CentOS 8 and nftables, that has been solved by usage of istio-cni plugin.

Seems to work now.