Exclude SSH port on virtual machines

Hello,

I have VMs that need to join a mesh but once I install the istio sidecar RPM (alongside istio files output from the istioctl workloadentry configure command) I directly loose SSH connection on the VM.

I know that you can exclude inbound/outbound ports from sidecar using annotations on PODs.

But how do you do that for VMs?

Thanks in advance

1 Like

I know this post is a bit old but in case you (or anyone else) are still having this issue, it looks like the latest version of Istio (1.13.2 as I write this) will include this setting when you run the istioctl x workload entry command to generate the config files to transfer to the VM.

But in case you need or want to define this manually, you can edit the cluster.env file update update the following setting like this:

ISTIO_LOCAL_EXCLUDE_PORTS='22,15090,15021,15020'