External Istiod with Helm v1.19.0 charts

I’m struggling a bit with the 1.19.0 helm charts and understanding how to enable remote istiod.

  # When set to true, istiod is not deployed locally and only a subset of the other
  # discovery charts are enabled.
  externalIstiod: true

When using this in my values It’s still deploying istiod locally in the remote cluster. What am I missing here?