How to set istio log level?

Hello,

I am attempting to set the istio log level through the manifest (specifically global.logging.level) and it’s having no impact on the logs produced. I’d like to only log errors/warnings. How do I do this?

edit Note: I checked the pods and nothing is changing – the switch is still setting debug, even when it’s defaulted to default:info.

1 Like

Did you try ControlZ?

Yeah – and so far I can’t seem to find the culprit. I am trying to turn off debug level logging for the sidecar injector. I’ll try all pods with controlz and see if that helps.

edit I can’t find sidecar injector settings and it seems to be ignoring the global.logging.level setting while some of the pods have that setting.

@haunted have you found the way to change log levels effectively?

what Istio version you use?
In 1.6, you can change in the values.global.proxy.logLevel

Hello Friends,
And do you know if it’s possible to set different log level to the different proxies?
As the one in values.global.proxy.logLeve sets the level for all proxy containers, and we’d prefer to have info level on some, and warn on others…

You can use istioctl pc log pod-name --level:debug command for this.