Istio-galley, istio-telemetry, istio-policy pods are in CrashLoopBackOff state


#1

Describe the bug

With Helm template:

I followed this link to configure ISTIO 1.1 - https://preliminary.istio.io/docs/setup/kubernetes/helm-install/

  1. helm repo add istio.iohttps://gcsweb.istio.io/gcs/istio-prerelease/prerelease/1.1.0-rc.1/charts/
  2. mkdir -p $HOME/istio-fetch
  3. helm fetch istio.io/istio-init --untar --untardir $HOME/istio-fetch
    helm fetch istio.io/istio --untar --untardir $HOME/istio-fetch
  4. kubectl create namespace istio-system
  5. helm template $HOME/istio-fetch/istio-init --name istio-init --namespace istio-system | kubectl apply -f -
  6. helm template $HOME/istio-fetch/istio --name istio --namespace istio-system | kubectl apply -f -

check pods in ISTIO-SYSTEM namespace

kubectl get pods -n istio-system
NAME READY STATUS RESTARTS AGE
istio-citadel-5bf5488468-wxdhc 1/1 Running 0 1h
istio-cleanup-secrets-release-1.1-latest-daily-67n4r 0/1 Completed 0 1h
istio-galley-7d66584fd5-29zd7 0/1 CrashLoopBackOff 24 1h
istio-ingressgateway-665ffb67b8-kr97c 0/1 Running 0 1h
istio-init-crd-10-qbmmb 0/1 Completed 0 1h
istio-init-crd-11-9d48w 0/1 Completed 0 1h
istio-init-crd-certmanager-10-7ml4d 0/1 Completed 0 1h
istio-pilot-78d956bf99-gqxpg 0/2 Pending 0 1h
istio-policy-7bd89845bd-xpvs7 1/2 CrashLoopBackOff 39 1h
istio-sidecar-injector-744f68bf5f-qh8xb 1/1 Running 0 1h
istio-telemetry-679f7fbbd8-qm49f 1/2 CrashLoopBackOff 39 1h
prometheus-89bc5668c-26gfw 1/1 Running 0 1h

ISTIO Version:

istioctl version
version.BuildInfo{Version:“1.1.0-rc.1”, GitRevision:“cdc39e70054be670d2c141dec7b8517a0812b021”, User:“root”, Host:“72433e36-3ac1-11e9-8dad-0a580a2c0205”, GolangVersion:“go1.10.4”, DockerHub:“docker.io/istio”, BuildStatus:“Clean”, GitTag:“1.1.0-rc.0-54-gcdc39e7”}

Helm version:

helm version
Client: &version.Version{SemVer:“v2.9.1”, GitCommit:“20adb27c7c5868466912eebdf6664e7390ebe710”, GitTreeState:“clean”}
Server: &version.Version{SemVer:“v2.9.1”, GitCommit:“20adb27c7c5868466912eebdf6664e7390ebe710”, GitTreeState:“clean”}

K8s version:
kubectl version
Client Version: version.Info{Major:“1”, Minor:“10”, GitVersion:“v1.10.7”, GitCommit:“0c38c362511b20a098d7cd855f1314dad92c2780”, GitTreeState:“clean”, BuildDate:“2018-08-20T10:09:03Z”, GoVersion:“go1.9.3”, Compiler:“gc”, Platform:“linux/amd64”}
Server Version: version.Info{Major:“1”, Minor:“11+”, GitVersion:“v1.11.7-gke.4”, GitCommit:“618716cbb236fb7ca9cabd822b5947e298ad09f7”, GitTreeState:“clean”, BuildDate:“2019-02-05T19:22:29Z”, GoVersion:“go1.10.7b4”, Compiler:“gc”, Platform:“linux/amd64”}


Unable to configure istio-1.1.0-rc.1 with helm and tiller
#2

Hi,

Can you share Galley logs?
kubectl logs -n istio-system


#3

Hi @ozevren

kubectl logs istio-galley-7d66584fd5-29zd7 -n istio-system
Error: unknown flag: --meshConfigFile


#4

Can you try using ImagePullPolicy: Always?
The current charts use “latest” tag, which doesn’t work well with IfNotExists type ImagePullPolicies. You end up running stale binaries. I suspect this is one of those cases.