Pilot trace sampling not settable set by istioctl

Hi, I’m deploying istio with helm with the following:

helm template install/kubernetes/helm/istio --name istio --namespace istio-system ... --set tracing.ingress.enabled=true --set pilot.traceSampling=100 >> istio.yaml

This is working correctly and I am seeing 100% of traffic in Jaeger. When I reconfigure stuff with istioctl this seems to break however.

istioctl manifest apply --set values.pilot.traceSampling=100

But it seems that pilot.traceSampling is defaulting to 1.0 - I have tried a few things such as setting PILOT_TRACE_SAMPLING but it seems to be ignored.