Setting the value of values.global.tracer.zipkin.address has no effect

Hello,

I’m trying to configure Jaeger for istio following the steps from the documentation. I have installed istio in my kubernetes cluster in namespace istio-system and Jaeger in namespace jaeger. Unfortunately the jaeger collector receives only data from the envoy proxies that are deployed in the same namespace (in my case in the namespace jaeger). I guess the proxies are sending tracing data to jaeger-collector.{CURRENT_NAMESPACE}.{K8S_NAMESPACE}. Setting the variable values.global.tracer.zipkin.address to the right address has no effect.

My configuration:
Istio version: control plane version: 1.14.2 / data plane version: 1.14.2

kubectl -n istio-system get cm istio -o yaml

apiVersion: v1
data:
  mesh:
    .
    .
    .
    defaultConfig:
      tracing:
        zipkin:
          address: jaeger-collector.jaeger.{K8S_NAMESPACE}.local:9411
    enableTracing: true

kubectl -n istio-system get deployment istiod -o yaml | grep -A 1 'name: PILOT_TRACE_SAMPLING'

- name: PILOT_TRACE_SAMPLING
  value: "100"

If I deploy the demo jaeger application everythink works fine.

What could be the issue? How can I override the jaeger collector url?