The tcp-echo example

Hello,
I’ve been trying to follow the istio 1.4.5 documentation around the TCP Traffic Shifting. When I get to step 3. Confirm that the tcp-echo service is up and running,
I run the listed command:

export INGRESS_PORT=$(kubectl -n istio-system get service istio-ingressgateway -o jsonpath=’{.spec.ports[?(@.name==“tcp”)].port}’)

When I check the INGRESS_PORT variable after running this command, the value is empty.

My istio-ingressgateway is of type LoadBalancer. My INGRESS_HOST is the LoadBalancer hostname. When I try setting the INGRESS_PORT using the following command:

export INGRESS_PORT=$(kubectl -n istio-system get service istio-ingressgateway -o jsonpath=’{.spec.ports[?(@.name==“http2”)].port}’)

and then try to verify the tcp-echo microservice:

for i in {1…10}; do
docker run -e INGRESS_HOST=$INGRESS_HOST -e INGRESS_PORT=$INGRESS_PORT -it --rm busybox sh -c “(date; sleep 1) | nc $INGRESS_HOST $INGRESS_PORT”;
done

I get:
nc: bad address ''

Has anyone else run into this issue? If so can you provide some insight on how this was resolved?

Thanks

Hi @rberna

when investigating my issues i found this which is related to your issues pls check

btw i have a another problem in this task pls have a look at : Tcp traffic shifting task bug if you know something so ppls help me.