Upgrading from 1.14.x to 1.15.x Breaks Connectivity with AWS ELB

Hi there,
I faced the issue long time ago and posted as an issue on GH main repository but didn’t get any response. I also asked shared the issue on Slack, and no reply there either. As the last resort, I’m asking the question here for help.
I’ve got a normal setup, nothing fancy, Istio default installation with AWS ELB (not ALB) + HTTPS. Everything works just fine. When I upgrade to 1.15.x (any version) the connectivity goes away, meaning I cannot open any of the previously accessible pages. (I gave more details in the issue.)
Just now I tried with 1.16.0 and still same issue. Another user reported the same issue.
Is this a bug or feature? Anyone knows anything? Would be wonderful at least if I know how to troubleshoot the issue. Thanks.

You ingress is creating new LB everytime, have you tried alb.ingress.kubernetes.io/load-balancer-attributes: "deletion_protection.enabled=true"

I’m not sure if I understand you correctly. It’s an ELB (not ALB) and there’s no ingress (backed by an ALB). If you mean, it’s a new service, thus a new ELB, that’s a valid point. And I tried it already, i.e. updated Route53 record, same issue.
Interestingly, there’s no issue when I configure the ELB listener to talk to Istio on HTTP. Everything works just fine. But when configure Istio with a SSL-Redirect and update the listener to talk to Istio on HTTPS, the timeout happens.

Is there any resolution to this?