Istio 1.2.3 grafana URL is not set in Kiali configuration

Hi all,
when I enabled kiali, grafana and tracing on istio 1.2.3 kiali gives the error

Error fetching Grafana Info., Error: [ grafana URL is not set in Kiali configuration ]

I have a two node cluster (a KVM machine with K3S as server and a KVM machine with K3S agent)
I installed istio with

sudo helm install install/kubernetes/helm/istio --name istio --namespace istio-system

Then I verified that everything worked and installed kiali, grafana and tracing with

sudo helm upgrade istio install/kubernetes/helm/istio --set grafana.enabled=true,kiali.enabled=true,tracing.enabled=true

After starting the two KVM machine and waiting that kubernetes dashboard gives all green, when I open in browser the kiali url I see a popup window with the error

Error fetching Grafana Info., Error: [ grafana URL is not set in Kiali configuration ]

The grafana page seems working (only “add users” is not cheked)

What can I do?

@jmazzitelli @jotak is this way of installing supported?

I’m following the instructions at

Option 2 helm + tiller

For K3S, their home page says it is a Kubernetes certified distribution

I have two lab installations:

  • 1 KVM virtual machine k3s 0.7.0 istio 1.2.2 --> everything works no errors
  • 2 KVM virtual machines k3s 0.7.0 (master + node) istio 1.2.3 --> kiali error missing grafana URL

Other than the grafana url error, everything else works included the bookinfo demo application

Any hint on what can I try?

Hi @MirtoBusico

First, note that this error only means that the links to Grafana dashboards, in the various metrics pages of Kiali, will not be displayed since Kiali could not acknowledge the presence of Grafana. Maybe you would have imagined something worse, but everything else in Kiali will still be working correctly (btw, we’ve changed that error message in more recent version of Kiali to make it less worrisome).

I’m not sure exactly why Grafana is not recognized out of the box here. But what you can do is to edit Kiali’s config map or CR to setup manually the URL of Grafana (or you could also disable links to Grafana from Kiali). I’m not sure which version of Kiali is deployed with Istio 1.2.3, and if there’s the kiali-operator or not (you can check if you have a namespace “kiali-operator”), so depending on that you would have to configure Kiali CR (if there’s kiali-operator) or config map (without operator).

URL setting is

    url: "..."

in the YAML.

I’ll try asap and report here

Ok found the error.
I don’t know why but grafana url is empty.
Here the generated configmap named “kiali”

sysop@k3s-server:~/software/localstorage$ sudo kubectl get configmaps kiali -o yaml -n istio-system
apiVersion: v1
  config.yaml: "istio_namespace: istio-system\nauth:\n  strategy: \"login\"\nserver:\n
    \ port: 20001\n  web_root: /kiali\nexternal_services:\n  tracing:\n    url: \n
    \ grafana:\n    url: \n  prometheus:\n    url: http://prometheus:9090\n"
kind: ConfigMap
  creationTimestamp: "2019-08-03T08:01:39Z"
    app: kiali
    chart: kiali
    heritage: Tiller
    release: istio
  name: kiali
  namespace: istio-system
  resourceVersion: "27683"
  selfLink: /api/v1/namespaces/istio-system/configmaps/kiali
  uid: ec4d81f1-b5c4-11e9-a1c5-5254003c3bca

Now I’ve to find the grafana url and insert it in the configmap