Kiali dashboard - distributed tracing; Querying adapter got an error

#1

I install Istio 1.1.4 using Helm. The actual install is as such:

helm install install/kubernetes/helm/istio --set tracing.enabled=true --set tracing.ingress.enabled=true --set pilot.traceSampling=100 --set grafana.enabled=true --set prometheus.enabled=true --set kiali.enabled=true --set “kiali.dashboard.jaegerURL=http://localhost:16686” --set “kiali.dashboard.grafanaURL=http://localhost:3000/dashboard/db/istio-mesh-dashboard” --name istio --namespace istio-system

I am able to access the Kiali console without issue. However, when I attempt to use the distributing tracing, within Kiali, I always get an error. The UI just says: “Error”. I get no explanation as to what the error is.
I pulled the logs for the Kiali pod and I see the following 2 errors:

istio_rules_service.go: 116] Querying adapter got an error: default doesn’t return a servicecontrols list
istio_rules_service.go: 116] Querying template got an error: default doesn’t return a servicecontrolreports list

I’ve done searches and I cannot find anything that points to what is missing or misconfigured. I do get the same issue with attempting to access Grafana from Kiali.

#2

Hi,
Could you give us more details ? If you check the network browser tab, is there any call to the backend with error ?

#3

Hi Lucas,

I don’t see a network browser tab? Which UI are you referring to?

  I did notice with the Grafana access I receive a 404; however, if

I enter the exact same URL in a browser window it works perfectly
fine.

#4

I mean if you access to the debug mode of your browser (in my case I use Chrome and I can access using CTRL+Shift+C keys).
Then you can see a network tab with the calls between the browser UI and the backend services.
Just wondering if that shows any additional info.
Also, if you access to the “?” icon in Kiali, can you post the info with the details of commits/versions and URLs listed there ?
Just to investigate in details if the problem is something missing in the config or version used.

#5

The debug info:

{
“backendConfigs”: {
“authenticationConfig”: {
“strategy”: “login”
},
“computedServerConfig”: {
“istioNamespace”: “istio-system”,
“istioLabels”: {
“appLabelName”: “app”,
“versionLabelName”: “version”
},
“prometheus”: {
“globalScrapeInterval”: 15,
“storageTsdbRetention”: 21600
},
“durations”: {
“60”: “Last 1m”,
“300”: “Last 5m”,
“600”: “Last 10m”,
“1800”: “Last 30m”,
“3600”: “Last 1h”,
“10800”: “Last 3h”,
“21600”: “Last 6h”
}
}
},
“currentURL”:

#6

This is the URL that is invoked: http://localhost:16686/search?uiEmbed=v0&start=1556638451486000&end=1556649251486000&limit=20&lookback=10800&maxDuration=&minDuration=&service=greeter-service.default

  When I explicitly enter the URL in a browser I receive the

response:

Error

Back Home

#7

Thanks for your response sherwoodzern.
Sorry for my delay, it was public holiday in my country and I couldn’t access to my email.

So, to confirm, when you use the url in a different tab/window of your browser:

http://localhost:16686/search?uiEmbed=v0&start=1556638451486000&end=1556649251486000&limit=20&lookback=10800&maxDuration=&minDuration=&service=greeter-service.default

Then, you get the error.

But if you use just http://localhost:16686/ can you see the Jaeger service ?
If yes, it sounds that the jaeger UI is exposed in a different location and that should be changed in the
–set “kiali.dashboard.jaegerURL=http://localhost:16686” param.

Can you check it ? For the record, there is an open PR in Kiali to try to auto-discover these URLs https://github.com/kiali/kiali/pull/1022 and only modify them on custom installations.

Could you help us to provide more details of your environment, perhaps we can use this issues to improve this setting and make it more easy to configure.

Thanks in advance.
Lucas

#8

Hey sherwoodzern.

What Jaeger version did you install? The embedded option was integrated in >1.8.

Thanks !!!

#9

From the kiali dashboard, the distributed tracing points to that endpoint. When I enter the search criteria, as you can see in the URL, this is what will be created. I get a response of “Error” when I hit the search button. If I copy the URL and paste into a browser I get the same response.

However, if I just access http://localhost:16686 then the traces will be retrieved. Now, I am doing a port-forward for the tracing pod.

If the jaegerURL that I specify is incorrect then how do I find the URL for the Jaeger dashboard when I deploy Istio using Helm?

#10

I am using Istio 1.1.4; therefore, what Jaeger version is shipped with Istio 1.1.4? Or, what version does it pull? I am not specifying any specific Jaeger version. I allow Istio to pull the version that is configured as part of Istio installation.

#11

Can you try this url http://localhost:16686/search?uiEmbed=v0&limit=20&lookback=1h&service=greeter-service.default ?

#12

I get the same Error response.

#13

Are there any updates to this inquiry?

#14

Hi sherwoodzern, It seems we don’t have enough info.
Are you willing to join us under #kiali room in freenode IRC chat ?
Perhaps we can try to have some online debug session to understand your scenario.

#15

I’d be happy to. How do I join the kiali room in freenode IRC
chat?

#16

Well, you can use any IRC client to access to the freenode network.
If you are not familiar with those, there is a more limited web one:
https://webchat.freenode.net/

Just log-in and enter in the kiali room

#17

Hi Sherwoodzern,

What do you think about make a call to check your environment? We can talk by IRC about, Where are you based or timezones?

Thanks.

#18

I’m based in the eastern U.S. I’m happy to have a call.

#19

Alberto,

I am able to connect to the Kiali channel for chat.

#20

ok let me a second I’m turning on the laptop that I had finished the job ^^