Jaeger Traces issue


Istio v1.0.5

I have deployed two services intercommunicating each other and I have enabled the istio features. I have injected the traffic using below command,

for i in seq 1 100; do curl -s -o /dev/null http://$GATEWAY_URL/url; done

When i check the traces using Jaeger dashboard i am able to see only one span istio gateway. I am not able to see the spans related to services deployed.

May I know the issue?

Have you seen the FAQ on Distributed Tracing ?

In addition to the FAQ that @douglas-reid has posted, you might find Help with Production Jaeger and Istio and Opencensus / Jaeger tracing disconnected from istio traces helpful. Configurable trace header proposal is something I’m tracking.

HI Anurag

take into account that default jaeger installation has just 1% sampling rate, so over 100 request just 1% is sent to jaeger for tracing (setting is visible on Pilot Pod), so the behaviour you are reporting is correct.

For a full tracing consider deploying a standalone Jaeger Operator with a persistence (default one has in-memory mode) and removing the “demo” setup coming with default istio install.

For version 1.0.5 take into account that you will have to change the “zipkin” service to point to the new jaeger collector since the endpoint name is hardcoded into istio configmap, parametrized configuration reported in last documentation is just for newer Istio release.

Hi @douglas-reid

Sorry for late reply,

I haven’t set the headers in the code. Is there anyway without changing the code so that i can get traces.


Hi @aroundthecode

I’ll try this method. But is there anything to be added/modified in the code if i install the jaeger operator?

If you aren’t setting the headers in your service code, there is no way to link spans together in a distributed trace. Context propagation is required for tracing to work.