Unable to configure istio-1.1.0-rc.1 with helm and tiller


#1

Hello Team,

I am unable to configure ISTIO 1.1.0-rc.1 using helm and tiller.

getting below error:

helm install istio --name istio --namespace istio-system
Error: failed to download “istio” (hint: running helm repo update may help)

and tried, helm repo update and still getting above error.

steps to reproduce:

I have followed below link to configure ISTIO 1.1

steps used:

  1. helm repo add istio.iohttps://gcsweb.istio.io/gcs/istio-prerelease/prerelease/1.1.0-rc.1/charts/
  2. kubectl apply -f install/kubernetes/helm/helm-service-account.yaml
  3. helm init --service-account tiller
  4. helm install istio.io/istio-init --name istio-init --namespace istio-system
  5. helm install istio --name istio --namespace istio-system
    at this step I am getting below error

Error: failed to download “istio” (hint: running helm repo update may help

ISTIO Version:

istioctl version
version.BuildInfo{Version:“1.1.0-rc.1”, GitRevision:“cdc39e70054be670d2c141dec7b8517a0812b021”, User:“root”, Host:“72433e36-3ac1-11e9-8dad-0a580a2c0205”, GolangVersion:“go1.10.4”, DockerHub:“docker.io/istio”, BuildStatus:“Clean”, GitTag:“1.1.0-rc.0-54-gcdc39e7”}

Helm version:
helm version
Client: &version.Version{SemVer:“v2.9.1”, GitCommit:“20adb27c7c5868466912eebdf6664e7390ebe710”, GitTreeState:“clean”}
Server: &version.Version{SemVer:“v2.9.1”, GitCommit:“20adb27c7c5868466912eebdf6664e7390ebe710”, GitTreeState:“clean”}

K8s version:
kubectl version
Client Version: version.Info{Major:“1”, Minor:“10”, GitVersion:“v1.10.7”, GitCommit:“0c38c362511b20a098d7cd855f1314dad92c2780”, GitTreeState:“clean”, BuildDate:“2018-08-20T10:09:03Z”, GoVersion:“go1.9.3”, Compiler:“gc”, Platform:“linux/amd64”}
Server Version: version.Info{Major:“1”, Minor:“11+”, GitVersion:“v1.11.7-gke.4”, GitCommit:“618716cbb236fb7ca9cabd822b5947e298ad09f7”, GitTreeState:“clean”, BuildDate:“2019-02-05T19:22:29Z”, GoVersion:“go1.10.7b4”, Compiler:“gc”, Platform:“linux/amd64”}


#2

For step 5, try:
helm install istio.io/istio --name istio --namespace istio-system


#3

Hi

I tried above command and ISTIO was configured but, istio-galley, istio-telemetry, istio-policy are in CrashLoopBackOff state.

kubectl get pods -n istio-system
NAME READY STATUS RESTARTS AGE
istio-citadel-5bf5488468-vtprx 1/1 Running 0 4m
istio-galley-7d66584fd5-sqt9c 0/1 CrashLoopBackOff 5 4m
istio-ingressgateway-665ffb67b8-mpjnm 0/1 Running 0 4m
istio-init-crd-10-t7h2k 0/1 Completed 0 7m
istio-init-crd-11-8s7rt 0/1 Completed 0 7m
istio-init-crd-certmanager-10-bdpnh 0/1 Completed 0 7m
istio-pilot-78d956bf99-6gjvx 0/2 Pending 0 4m
istio-policy-7bd89845bd-qx5rk 1/2 CrashLoopBackOff 6 4m
istio-sidecar-injector-744f68bf5f-m27r6 1/1 Running 0 4m
istio-telemetry-679f7fbbd8-7k5j9 1/2 CrashLoopBackOff 6 4m
prometheus-89bc5668c-dbgtw 1/1 Running 0 4m

kubectl logs istio-galley-7d66584fd5-sqt9c -n istio-system
Error: unknown flag: --meshConfigFile

for above error, I have gone through below discussion and fallowed and still not able to configue istio

  1. https://github.com/istio/istio/issues/9876
  2. Istio-galley, istio-telemetry, istio-policy pods are in CrashLoopBackOff state

#4

Are you still getting the same error after updating the ImagePullPolicy to Always?

Can you dump the contents of the galley deployment?

kubectl -n istio-system get deployment istio-galley -o yaml


#5

Hi @ozevren

kubectl -n istio-system get deployment istio-galley -o yaml



containers:
- command:
- /usr/local/bin/galley
- --meshConfigFile=/etc/mesh-config/mesh
- --livenessProbeInterval=1s
- --livenessProbePath=/healthliveness
- --readinessProbePath=/healthready
- --readinessProbeInterval=1s
- --insecure=true
- --validation-webhook-config-file
- /etc/config/validatingwebhookconfiguration.yaml
- --monitoringPort=15014
image: gcr.io/istio-release/galley:release-1.1-latest-daily
imagePullPolicy: IfNotPresent
livenessProbe:
exec:
command:


imagePullPolicy still showing IfNotPresent, so its not reflected here,

can you please tell me the path where to update imagePullPolicy to Always.


#6

Ok, it looks like the images have been updated but the helm charts have not. Could you run:
kubectl -n istio-system edit deployment istio-galley
and
add this:

- /usr/local/bin/galley
- server      <=== add this
- --meshConfigFile=/etc/mesh-config/mesh

It looks like charts and the images are not in sync at the moment. For future reference, you can also do the same thing (kubectl edit) to edit and replace the image pull policy.


#7

@ozevren
after adding “server” , pods are came to running state.

can you please tell how to overcome this issue at the time of configuration?

( not with kubectl edit)


#8

The charts are referring to “latest” images, which gets updated more frequently than the charts. Ideally they should target specific builds, so that this is a non-issue.

When 1.1. releases, the charts and the binaries will be in-sync, so this won’t be an issue.


#9

Thank You :slight_smile: